BugsReconocidos

Versión 1.3 #

Debido a un bug en los drivers opensc de linux (ajeno a la aplicación sinadura) no es posible utilizar más de un certificado de tipo pkcs11 (tarjeta) a la vez. Sí es posible almacenar la configuracion de varias tarjetas en gestión de certificados pero sera necesario reiniciar la aplicación y usar únicamente uno en cada sesión. Debido a este bug además una vez que se hace una carga errónea de una tarjeta (por no tener introducida la tarjeta correcta por ejemplo) el lector se queda bloqueado y no se podrá volver a cargar ninguna otra durante esa ejecución, de modo que sera necesario reiniciar también la aplicación.

Para evitar que el lector de tarjetas se quede bloqueado, cuando aparezca la ventana con el mensaje Antes de proseguir asegúrese de introducir la tarjeta: XXXXX deberíamos pulsar el botón cancelar siempre que la tarjeta que se nos indica en dicho mensaje (XXXXX) no sea la tarjeta con la que realmente queremos firmar.

En windows sí es posible usar varias tarjetas del mismo tipo pero en caso de utilizar de distinto tipo sera necesario reiniciar la aplicación del mismo modo que en el caso anterior.

Por tanto debido a estos bugs recomendamos usar únicamente una tarjeta a la hora de firmar, y reiniciar siempre la aplicación en caso de querer utilizar otra.

Bugs Menores o Mejoras #

Algunos de estos cambios se han recogido de los comentarios de la web o por el servicio de incidencias

  • Búsqueda por defecto de la librería /usr/lib/opensc/opensc-pkcs11.so
  • Nombres más amigables - more user friendly- para la descripción del tipo de certificado, de software o de tarjeta criptográfica
  • Sistema visual para los parámetros de la posición del logotipo
Promedio (0 Votos)
Comentarios